Company: Link Technologies
Case No: L10422. Project: 11.40: LinkSOFT Version 11.4
Logged By: Rashna (Edge Business Solutions) on 29 May 2019 01:35PM
Priority: Medium
Product: Payroll & HR
Group: Software Defect
Time Taken: 9.00 (Weight: 9.00)
Version: 11.3.0902
Assigned To: Sanjay (Link Technologies)
Circulation: Alvis, Development, Rashna, Sanjay
Resolve By: Thursday, 30 May 2019 12:00 AM [1786 days since logged date]
Status: Closed
Subject: "User Employee Rate" is not functional under "Customer Project/Rates".
Summary:    

The following was done.

  1. Add activity "Accommodation" to project "JIWA Financial".
  2. Added project "JIWA Financials" for customer "CK".
  3. Set the rate to "Use Employee Rate" for the project "JIWA Financial" under  "Customer Project/Rates" for customer CK.
  4. I created a time entry for employee E001, the system picked rate as 1. Please advise where its been extracted
Audit Notes:Edited by sanjay on 08/12/20 09:20. Edited by rashna on 21/06/19 10:08. 
29 May 201901:35PM Comment 1 by Rashna (Edge Business Solutions) Case 10422 added to project 11.0
12 Jun 201901:05PM Comment 2 by Rashna (Edge Business Solutions) Assigned To: Rashna (Edge Business Solutions) Followup Date: 12-06-2019 01:05 PM Time Taken: 1.50 Notes: Edited by rashna on 21/06/19 10:15. 

Hi Rashna,

The "Use Employee Rate" flag uses the rates defined in "User Maintenance"

regards
Alvis


21 Jun 201910:14AM Comment 3 by Rashna (Edge Business Solutions) Assigned To: Alvis (Link Technologies) Followup Date: 28-06-2019 12:00 AM Time Taken: 2.50

Hi Alvis, 

I tested the case as per comment 2, however, the rates were picked from user maintenance.

Steps to Replicate

  1. Set the rate for "company 1001" for user "Alvis" as 33.33.
  2. Navigate to "Time Maintenance - Customer Project/ Rates"
    1. Select customer "CK"
    2. Set "Use Employee Rate" for project "Link HR".
  3. Login as "Admin" and create the time entry for "Alvis". The entry does not pick rate in 1 above.

24 Jun 201909:39AM Comment 4 by Sanjay (Link Technologies) Assigned To: Development Followup Date: 24-06-2019 09:39 AM Time Taken: 2.50

Development work for this case has been completed.

The change will be available in version: 11.0.0624

1. The following changes were made(Include Database object names, Program classes and any other relevant information):|

  1. Corrected the get rate procedure to use loaded employee id instead of the logged in username

2. The issue was caused by:

  1. Incorrect username used to get rate.

3. Next Step:

  1. UAT

4. Notes:


26 Jun 201902:32PM Comment 5 by Rashna (Edge Business Solutions) Assigned To: Sanjay (Link Technologies) Followup Date: 26-06-2019 02:32 PM Time Taken: 2.50
QA Results
Tests carried out according to requirements specified on the case header

Test Results Summary

Table 1 - Summarised list of issues
NoTest DescriptionPass/Fail
1
  1. Set the rate for "company 1001" for user "Alvis" as 33.33.
  2. Navigate to "Time Maintenance - Customer Project/ Rates"
    1. Select customer "CK"
    2. Set "Use Employee Rate" for project "Link HR".
  3. Login as "Admin" and create the time entry for "Alvis". Rate of $33.00 should be depicted
Pass
2Log in as "Alvis" and create time entry with above details, rate of $33.00 should be depicted Pass

Documentation has been updated at this link.

Environment Details

  1. OS version: Windows Server 2012
  2. Application version: 11.0.0624 BETA
  3. Setup: Demo
  4. Server : 10.0.0.14
  5. Database: LINKSOFT-DEMO-11-RASHNA

Next Step: Closure


    09 Oct 201908:17AM Comment 6 by Sanjay (Link Technologies) Quality control status: Pass. QC Not required - Cleared queue due to large number of calls
    If you have any queries regarding this support incident, please email admin@linktechnologies.com.au and include the Case No: L10422 in the subject line of all emails regarding this issue.

    Document size: 6.1 KB
    For call complaints, please contact the Managing Director of the company using this form